Rieju & GasGas Legacy Riders Club Forum  

Go Back   Rieju & GasGas Legacy Riders Club Forum > GasGas Enduro Technical Forums > Enduro Electrical & Wiring

Enduro Electrical & Wiring Lighting, Ignition, Wiring, Plugs, etc.


Reply
 
Thread Tools Display Modes
  #1  
Old 04-28-2019, 12:01 PM
mvidlak mvidlak is offline
Member
 
Join Date: Apr 2019
Posts: 4
Post ec300 stator?

Hi all, my first post and I've been reading through similar issues here and found lot of good info. Still have some Qs though. I'm sorry I can deal with most mechanical issues but electrical is new and hard for me...

I have 2011 ec300 6days.

Few months ago my lights stopped working (from on/off for a while - sometimes they would still come on when wide open, to completely dead) I thought maybe just broken wire somewhere but didn't really pay much attention to it. Now I have no spark. Went through wires/continuity/grounds everything looks ok. I'm not sure if I trust my multimeter as I've been getting some weird readings (I'll try new one this week, also found some readings posted here) I'm still getting some voltage to cdi and coil when i kick but no spark. I also put coil with wire and spark plug to my ktm to test it and I get spark there. So my guess is a bad stator?
I'm waiting for flywheel puller to look in there... Is there anything else/specific I should be looking for that could cause this (other than stator)? Also it seems hard to find a stator in US. Maybe I'll have better idea when I pull it. But just searching google with part number I'm getting different results. Anyone know what stator to buy (in US)? My wires come out the rear of the cover...Any part numbers?

Thanks!!


Reply With Quote


  #2  
Old 04-28-2019, 06:45 PM
Jakobi's Avatar
Jakobi Jakobi is offline
Super Moderator
 
Join Date: Oct 2010
Location: Australia
Posts: 7,994
Default

You should be able to find the resistance readings for the stator coils. Check them with your multi meter and ensure they are in range.

Pull the stator cover and flywheel and physically inspect the coils.

If you need to replace the OEM ones are silly expensive. Ktm sells the same stator for a fraction of the price.. but you then need to splice the loom (it's not plug and play).

All the info you need is in this thread: http://www.gasgasrider.org/forum/sho...ghlight=stator
Reply With Quote
  #3  
Old 04-28-2019, 07:00 PM
mvidlak mvidlak is offline
Member
 
Join Date: Apr 2019
Posts: 4
Default

Wow, this is great info! I guess I need to get little better searching this forum Thanks a lot! I was wondering if I could just go with KTM stator... I'll pull flywheel and look into this later this week.
My backup KTM is happy to be out on trails now, but I hope it's not for too long
Reply With Quote
  #4  
Old 04-28-2019, 09:47 PM
Jakobi's Avatar
Jakobi Jakobi is offline
Super Moderator
 
Join Date: Oct 2010
Location: Australia
Posts: 7,994
Default

All good mate! I went through the same thing recently when my 13 model had a winding come loose on a pole.. luckily only lost the lighting circuit and not the spark.
Reply With Quote
  #5  
Old 05-10-2019, 02:15 PM
mvidlak mvidlak is offline
Member
 
Join Date: Apr 2019
Posts: 4
Default

Update. Just in case someone comes to this with same issue...

KTM stator is a perfect fit, comes with pickup, wiring is super easy as ktm has exactly same color codes.

$100 and 1 hour later I have spark and lights back. Also my bike took few kicks to start in last couple months (before it died) and ran really rich. Didn't think all these issues were connected. Always blamed it on something else Now first kick no matter what and runs perfect.

Thanks again!
Attached Images
File Type: jpg IMG_20190506_194752.jpg (111.5 KB, 46 views)
File Type: jpg IMG_20190510_094608.jpg (117.6 KB, 50 views)
Reply With Quote
  #6  
Old 05-10-2019, 09:46 PM
Jakobi's Avatar
Jakobi Jakobi is offline
Super Moderator
 
Join Date: Oct 2010
Location: Australia
Posts: 7,994
Default

Yep and yep!! Good work mate!
Reply With Quote
Reply

Tags
ec300, stator



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Stator wires on o3 ec300 Dnf-init Enduro Electrical & Wiring 4 03-09-2016 04:53 PM
EC300 2k-2/1 stator - run on batteries stian Enduro Electrical & Wiring 9 02-19-2015 12:09 PM
ec300 stator on xc300? Jeremyxc300 Enduro Electrical & Wiring 3 05-22-2013 08:06 PM
Need larger stator for 05 EC300 ktm300exc Enduro Electrical & Wiring 7 10-15-2010 04:14 AM
EC300 Stator Output Magellan Enduro Electrical & Wiring 10 07-21-2006 12:12 PM




All times are GMT -5. The time now is 08:02 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
Copyright 2009 - GasGasRider.org