GasGas Riders Club Forum  

Go Back   GasGas Riders Club Forum > GasGas Enduro Technical Forums > Enduro Engine - 2 stroke

Enduro Engine - 2 stroke Cylinder, Piston, Tranny, Bearings, Clutch, Pipes & Silencers, etc.


Reply
 
Thread Tools Display Modes
  #1  
Old 08-27-2019, 02:57 AM
Cox76y Cox76y is offline
Senior Member
 
Join Date: Oct 2012
Posts: 170
Default Frustrating powervalve problem 2018 ec300

Ive just pulled the cover off the right hand side powervalve and removed the lever arm and pulled it off the powervalve. I then removed the small metal plate that connects the arm to the powervalve shaft so i could view the bearing.
Now I am in the process of putting it back together and I am having problems. I can see that this metal plate should spin and make contact with the small screw beside the bearing but it is not going far enough in either a clockwise or counterclockwise direction to make contact with it. It is as though the shaft has moved somehow and it just doesnt want to spin far enough for me to slip the plate back on.
Very hard for me to explain it but I hope someone knows what I am talking about. Also, the actuating rod seems to be stuck in the up position and needs a considerable amount of force to move down.. Is this normal.
thanks

JC


Reply With Quote


  #2  
Old 08-27-2019, 03:43 AM
Gasser Nate's Avatar
Gasser Nate Gasser Nate is online now
Senior Member
 
Join Date: May 2010
Posts: 252
Default

It has not spun 180 degrees out has it? Take a look up the exhaust port to see the flap is not hanging too low. Regarding the power valve arm, if you pulled up on it with it disconnected you may have dislodged one of the balls which requires the inner clutch cover to be removed to rectify. Did the power valve just get cleaned?
__________________
Back on a gassy! 2018 EC300! 🤘
Reply With Quote
  #3  
Old 08-27-2019, 04:18 AM
Cox76y Cox76y is offline
Senior Member
 
Join Date: Oct 2012
Posts: 170
Default

Not sure what went on here. Just went out to look at it after dinner and I can put it on fine. Everything lines up now..
Gassernate thanks again..
JC
Reply With Quote
Reply



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
EC 300 2018 starter problem eralha Enduro Electrical & Wiring 69 10-02-2019 12:11 PM
GG EC 300 '01 - Rebuild // Powervalve problem Hugo4x4 Enduro Engine - 2 stroke 6 06-14-2017 07:10 AM
Powervalve Drive Shaft EC300 Leeday "Wanted to Buy" & "Want To Trade" 4 08-17-2015 03:55 AM
Another Powervalve problem J-Meier Enduro Engine - 2 stroke 5 04-13-2015 12:53 PM
powervalve/top end problem still! moff747 Enduro Engine - 2 stroke 13 02-22-2008 07:21 AM




All times are GMT -5. The time now is 06:54 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright 2009 - GasGasRider.org