Rieju & GasGas Legacy Riders Club Forum  

Go Back   Rieju & GasGas Legacy Riders Club Forum > GasGas Enduro Technical Forums > Enduro Electrical & Wiring

Enduro Electrical & Wiring Lighting, Ignition, Wiring, Plugs, etc.


Reply
 
Thread Tools Display Modes
  #1  
Old 09-09-2016, 02:32 AM
bluespark's Avatar
bluespark bluespark is offline
Senior Member
 
Join Date: May 2013
Location: CO
Posts: 124
Default Fuse Block

When I removed the 10a fuses from my 12' 300 they were fairly tough to remove and one was brittle and maybe broken, not blown.

When I put new ones in I tried to push them in as hard as I could, but they didn't seem to seat real well and only seem to be held in by the plastic caps. Do I need to try harder to jam them in for a more solid connection?


Reply With Quote


Reply



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FSE 400 2002 Fuse values outland75 Enduro Electrical & Wiring 1 02-27-2016 03:17 AM
fuse location Mark b Enduro Electrical & Wiring 1 02-27-2016 03:13 AM
Fuel Pump Fuse (A8) on GG450 blowing Crankin04 Enduro Engine 4 stroke (including EFI & Exhaust) 5 08-30-2010 11:41 AM
Ken Block...at it Again! Rick Pictures & Videos 5 11-06-2009 12:56 PM
Where's The Lighting System Fuse?!!! JGress Enduro Engine 4 stroke (including EFI & Exhaust) 5 05-21-2008 08:24 AM




All times are GMT -5. The time now is 08:17 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
Copyright 2009 - GasGasRider.org