GasGas Riders Club Forum  

Go Back   GasGas Riders Club Forum > GasGas Enduro Technical Forums > Enduro Engine 4 stroke (including EFI & Exhaust)

Enduro Engine 4 stroke (including EFI & Exhaust) 4 stroke engine, EFI, and exhaust discussion


Reply
 
Thread Tools Display Modes
  #1  
Old 06-21-2012, 02:36 AM
Headhunter99's Avatar
Headhunter99 Headhunter99 is offline
Member
 
Join Date: Jun 2012
Location: Everett, Wa
Posts: 4
Question 2003 400 FSE Fuel Injection Issues

Hi all,
Boy have I got a story for you. I bought this 2003 400 FSE end of last year and got to ride it all of 3 months before it gave out on me. It's got that common problem of the Fuel pump not priming when the ignition is turned on. Plus the fuel pump does not turn on after the starter has spooled and stopped. So I've changed everything in the system I could get parts for. I've also scoured this forum for any other similar occurance and tried all those fixes, ignition swtch, kill switch, etc.

First were the fuses and the relay. $11

So, yes, I jumpered over where the relay would be, and the fuel pump runs and pumps fuel. That of course was after I bought a new OEM fuel pump from Gofasters... $950

I've checked the original relay that was in there and the replacement relay I got by putting direct power through and both actuate.

I figured since the fuel pump relay actuation is an ECU function "maybe the ECU was fried" so new Magneti Marelli 15P $450... No change.

Since I can't find ANYWHERE a wiring diagram for the 2003 400 FSE, I've been going off of the 450 FSE for at least reference. If anybody has a link or reference to a way I can get a wiring diagram I'd be very grateful.

Having gotten fed up with not having any luck with physically changing parts to get it working and all of the wiring seeming to be in good working order (no opens or shorts where there shouldn't be) I looked for dealership support, and was told by both (relatively) local dealers that they "don't work on that" one because it was a four-stroke, and the other because it's fuel injected.

Total so far $1411 - Bought the bike for $3000
Now I found the Biketech OBD tool online for $1250, but before I jump to buying that I was going to put the call out to all my fellow Gas Gas enthusists to find out if there is a dealer or other shop in Washington or Oregon that has a diagnostic tool I can plug into to see if there's any codes I can clear and turn this boat anchor back into a motorcycle. I'm in Western Washington, But i'm willing to take a road trip if I have to.

I love it when it runs, best bike I've had yet. But does me no good if it wont start.

Thanks


Reply With Quote


  #2  
Old 06-24-2012, 02:25 AM
bergerhag's Avatar
bergerhag bergerhag is offline
Gold Level Site Supporter
 
Join Date: Nov 2006
Location: Timr?, Sweden
Posts: 675
Default

Have you verified that the ecu actually gets power when you turn the key?
Reply With Quote
  #3  
Old 07-04-2012, 11:34 AM
Qui-gon's Avatar
Qui-gon Qui-gon is offline
Senior Member
 
Join Date: Dec 2007
Location: Lantana Fl
Posts: 200
Default

I would suspect the wiring...can you recall the symptoms when it quit?

Does anything else light up when you turn on the ignition switch?

The ECU has a permanent live on pin 17 via a fuse, the ignition switch just signals the ecu to start but it powers lights and stuff as well.

Forget the diagnostic kit for the time being, it will probably only tell you what you already know!

If your ecu is live on pin 17 and with the ignition switch on it supplies 12v on ecu pin 26 you need to check that ecu pin 19 goes low. This is the fuel pump relay trigger and grounds the relay coil. There is a blocking diode between that pin and the relay. The position of that diode is not certain. Mine is on the back of the relay socket but it could be taped in the harness somewhere between the relay and the ecu (nightmare). The 12v supply to the relay coil is off the ignition switch.

Hope that helps
__________________
06 Gas Gas FSE 450 USA
07 Gas Gas FSR 450 UK with motard and dirt wheels
Reply With Quote
  #4  
Old 08-15-2012, 04:58 PM
Headhunter99's Avatar
Headhunter99 Headhunter99 is offline
Member
 
Join Date: Jun 2012
Location: Everett, Wa
Posts: 4
Default

Thanks for the tips, just got internet set back up. I'm going to ring out those wires and get back to ya.
__________________
2003 Gas Gas 400FSE
2003 Honda XR250R
1986 Kawasaki KDX80
1974 Honda Elsinore MT250
Reply With Quote
  #5  
Old 08-15-2012, 07:26 PM
Headhunter99's Avatar
Headhunter99 Headhunter99 is offline
Member
 
Join Date: Jun 2012
Location: Everett, Wa
Posts: 4
Default

So I checked those wires. Verified I'm getting Voltage to Pin 26 When Ignition is switched on, then getting no voltage when switched off. Verified Pin 17 has permanent 12V. Diode was oriented correctly. Removed Diode (located in the fuse box and soldered into a Buss fuse adapter) to check for back voltage from pin 19. None. switching off and on I get a constant 4 Ohms of resistance. there is no change in readings. With the diode in I get constant voltage across the diode heading to pin 19 whether the ignition is switched on or off. It seems as though the relay actuation circuitry is not grounding, but I'm not sure what to do now, I've already tried a different ECU and cleaned all the ground connections I could locate.
__________________
2003 Gas Gas 400FSE
2003 Honda XR250R
1986 Kawasaki KDX80
1974 Honda Elsinore MT250
Reply With Quote
  #6  
Old 08-16-2012, 12:56 AM
bergerhag's Avatar
bergerhag bergerhag is offline
Gold Level Site Supporter
 
Join Date: Nov 2006
Location: Timr?, Sweden
Posts: 675
Default

There should not be any voltage on pin 19, using an ohm-meter to measure on live electronics is sure to get irratic results. Can you get the fuel pump relay to pull if you ground the cable to pin 19? (migth wanna disconnect it from the ecu first.

I have attached a different schematic, an older version. Might do you some good.
Attached Files
File Type: pdf 46. Scheme A3 Electronic Ignition IAW 15P.pdf (73.8 KB, 243 views)
Reply With Quote
  #7  
Old 08-16-2012, 08:34 AM
Nick's Avatar
Nick Nick is offline
Gold Level Site Supporter
 
Join Date: Jul 2006
Location: Nevada
Posts: 560
Default

Maybe i'm to simple for this, but you jumpered across where the relay goes and it pumps up like it should ? And yet you dont think its the relay ?
__________________
Dont follow me, You wont make it.
Reply With Quote
  #8  
Old 08-16-2012, 12:48 PM
Qui-gon's Avatar
Qui-gon Qui-gon is offline
Senior Member
 
Join Date: Dec 2007
Location: Lantana Fl
Posts: 200
Default

Quote:
Originally Posted by bergerhag View Post
There should not be any voltage on pin 19, using an ohm-meter to measure on live electronics is sure to get irratic results. Can you get the fuel pump relay to pull if you ground the cable to pin 19? (migth wanna disconnect it from the ecu first.

I have attached a different schematic, an older version. Might do you some good.
Perhaps I didn't make it clear.....pin 19 ecu is the switching line for the fuel pump relay. If the fuel pump relay is on (closed) there will be no voltage at that pin. When the pump cycles off after 2 or so seconds of no engine rotation that line will rise to battery volts less the coil and diode voltage drops. As soon as the crank pulser detects movement the ecu grounds that line turning on the relay. As Nick said you might want check the relay and its connections first to make sure the relay is ok. If pin 19 doesn't ever ground the relay then it could be one of the inputs or outputs from the ecu that are the problem. The ecu tests all the sensors, the coil and the injector before it will ground that pin 19. There are from memory 3 failures that will prevent the ecu from allowing the engine to start and therefore will not ground the pump relay pin. There may be more. They are a shorted or open coil, a shorted or open injector and an input from the tps which is outside the normal operating limits. The water, air and pressure sensors are also checked but if they have faults the ecu will run with a set of defaults and allow starting to be attempted.
Hope that helps

BTW bergerhag the diagram is almost the same as the later ones except for the led I believe
__________________
06 Gas Gas FSE 450 USA
07 Gas Gas FSR 450 UK with motard and dirt wheels
Reply With Quote
  #9  
Old 08-18-2012, 11:45 AM
Jim Cook's Avatar
Jim Cook Jim Cook is offline
Platinum Level Site Supporter
 
Join Date: Sep 2006
Location: Smackover, Arkansas (AR)
Posts: 622
Thumbs up

Quote:
Originally Posted by Headhunter99 View Post
-snip-
Now I found the Biketech OBD tool online for $1250, but before I jump to buying that I was going to put the call out to all my fellow Gas Gas enthusists to find out if there is a dealer or other shop in Washington or Oregon that has a diagnostic tool I can plug into to see if there's any codes I can clear and turn this boat anchor back into a motorcycle. I'm in Western Washington, But i'm willing to take a road trip if I have to.

I love it when it runs, best bike I've had yet. But does me no good if it wont start.

Thanks
The Magnetti Marelli Motorbike Diagnostic Program that is used by Gas Gas is also used (or was, in 2004) by Harley Davidson, Triumph, and Moto Guzzi (and maybe Ducatti). Just plug in the interface cable to the plug under the seat, near the battery. The user will have to first set the program to work for the "15P" ECU; and then it will diagnose the complete engine management system.

The dealer cost on that system was around $400 at the time, so I don't think it would be nearly as expensive as the program you mentioned. You may be able to get a semi-local dealership to put your bike on their diagnostic program for a nominal fee.

One more thought. One time, I couldn't figure out why the fuel pump on my 2003 FSE400 wasn't kicking on when I turned on the key. The most I could get was a "fast clicking" from the fuel pump relay. After waiting for and installing new fuel pump relays, I figured out that my battery was too weak to work the fuel pump. After a new battery, it ran fine, even after I reinstalled the old relays.

Good Luck with your problem.
Jim
__________________
Jim Cook
Smackover Racing
Team LAGNAF
'11 Gas Gas EC250 (primary ride)
'06 Gas Gas DE300
'94 Husaberg FE350
'86 Yamaha IT200 AHRMA CC Race bike
Several others, including project bikes, Deb's bike, and a fleet of grandkids' bikes

Let's go riding!
http://www.jebruns.com/Wudi19/wudi19.html
http://www.ahrma.org/schedules-results/cross-country/

Last edited by Jim Cook; 08-18-2012 at 12:47 PM.
Reply With Quote
  #10  
Old 08-19-2012, 05:01 AM
bergerhag's Avatar
bergerhag bergerhag is offline
Gold Level Site Supporter
 
Join Date: Nov 2006
Location: Timr?, Sweden
Posts: 675
Default

ECU diag program from Technoresearch $229 http://technoresearch.com/index.php?pid=37
Reply With Quote
Reply

Tags
enduro, fse400, fuel injection, parts, wiring



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
fuel injection fine tuning bigm2003 General Discussions & Announcements 2 09-06-2010 04:25 AM
Adjusting the Fuel Injection sanderjavant Enduro Engine 4 stroke (including EFI & Exhaust) 24 06-18-2010 02:03 PM
Fuel cap issues kendunn Enduro Intake/Carburetion - 2 stroke 6 06-12-2009 03:52 PM
2T Fuel Injection kim General Discussions & Announcements 6 04-14-2008 09:55 AM
Fuel Injection kim General Discussions & Announcements 1 08-25-2007 05:55 PM




All times are GMT -5. The time now is 07:38 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright 2009 - GasGasRider.org